You may have run into this error while resizing an existing ext4 partition:

resize2fs /dev/rootvg/lv_root
resize2fs: Filesystem has unsupported feature while trying to open /dev/rootvg/lv_root
Couldn't find valid filesystem superblock.
You will encounter this if you follow Red Hat’s documentation on ext4 resizing.  The error comes from a mistake in the documentation.  The correct command is resize4fs, not resize2fs for an ext4 filesystem.
resize4fs /dev/rootvg/lv_root

A relatively easy one to fix but not so easy to identify since the official documentation acts like resize2fs will work just fine.

Post to Twitter